Austin Group Defect Tracker

Aardvark Mark IV


Viewing Issue Simple Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Type Date Submitted Last Update
0000099 [1003.1(2008)/Issue 7] System Interfaces Editorial Omission 2009-06-29 20:19 2009-08-27 17:03
Reporter geoffclare View Status public  
Assigned To ajosey
Priority normal Resolution Duplicate  
Status Closed  
Name Geoff Clare
Organization The Open Group
User Reference
Section dlopen
Page Number 733
Line Number 24663
Interp Status ---
Final Accepted Text
Summary 0000099: dlopen return on success
Description _____________________________________________________________________________
 EDITORIAL Enhancement Request Number 29
 gwc:xxxxxxxxxxxxx Defect in XSH dlopen (rdvk# 2)
 [gwc dlopen return on success] Wed, 8 Apr 2009 09:43:15 +0100
 _____________________________________________________________________________

The RETURN VALUE section on the dlopen() page does not state what
 the function returns on success, only on failure.
Desired Action Insert

     "Upon successful completion, dlopen() shall return a handle for
     the executable object file specified by the file argument."

 before

     "If file cannot be found, ..."
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000208)
Don Cragun (manager)
2009-08-27 16:52
edited on: 2009-08-27 16:55

The requested changes have been incorporated in a larger set of changes
to dlclose(), dlopen(), and dlsym() in 0000074.

Therefore, this issue has been closed as a duplicate of that bug.


- Issue History
Date Modified Username Field Change
2009-06-29 20:19 msbrown New Issue
2009-06-29 20:19 msbrown Status New => Under Review
2009-06-29 20:19 msbrown Assigned To => ajosey
2009-06-29 20:19 msbrown Name => Mark Brown
2009-06-29 20:19 msbrown Organization => IBM
2009-06-29 20:19 msbrown Section => dlopen
2009-06-29 20:19 msbrown Page Number => 733
2009-06-29 20:19 msbrown Line Number => 24663
2009-06-29 20:20 msbrown Status Under Review => Resolved
2009-06-29 20:20 msbrown Resolution Open => Accepted
2009-07-01 18:10 Don Cragun Name Mark Brown => Geoff Clare
2009-07-01 18:10 Don Cragun Organization IBM => The Open Group
2009-07-01 18:10 Don Cragun Reporter msbrown => geoffclare
2009-08-27 16:52 Don Cragun Interp Status => ---
2009-08-27 16:52 Don Cragun Note Added: 0000208
2009-08-27 16:52 Don Cragun Resolution Accepted => Duplicate
2009-08-27 16:55 Don Cragun Note Edited: 0000208
2009-08-27 17:03 Don Cragun Status Resolved => Closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker