Austin Group Defect Tracker

Aardvark Mark IV


Viewing Issue Simple Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Type Date Submitted Last Update
0000100 [1003.1(2008)/Issue 7] System Interfaces Editorial Omission 2009-06-29 20:22 2009-08-27 17:04
Reporter geoffclare View Status public  
Assigned To ajosey
Priority normal Resolution Duplicate  
Status Closed  
Name Geoff Clare
Organization The Open Group
User Reference
Section dlsym
Page Number 735
Line Number 24705
Interp Status ---
Final Accepted Text
Summary 0000100: dlsym return on success
Description _____________________________________________________________________________
 EDITORIAL Enhancement Request Number 30
 gwc:xxxxxxxxxxxxx Defect in XSH dlsym (rdvk# 1)
 [gwc dlsym return on success] Wed, 8 Apr 2009 09:43:51 +0100
 _____________________________________________________________________________

 The RETURN VALUE section on the dlsym() page does not state what
 the function returns on success, only on failure.
Desired Action Insert

     "Upon successful completion, dlsym() shall return the address of
     the named symbol."

 before

     "If handle does not refer ..."
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000148)
geoffclare (manager)
2009-07-02 15:48

In view of the recent discussion of XSH 2.12.3, I think that it would
be a good idea to mention functions explicitly in the dlsym()
RETURN VALUE section.

I suggest that instead of inserting the text proposed in the
Desired Action, we should instead insert:

    "Upon successful completion, if the named symbol refers to a
    function, dlsym() shall return the address of the function
    converted from type pointer to function to type pointer to
    void, otherwise dlsym() shall return the address of the named
    symbol."
(0000209)
Don Cragun (manager)
2009-08-27 17:04

The resolution proposed here has been incorporated in a larger set if
changes to dlclose(), dlopen(), and dlsym() in 0000074.

Therefore, this issue has been closed as a duplicate of that bug.

- Issue History
Date Modified Username Field Change
2009-06-29 20:22 msbrown New Issue
2009-06-29 20:22 msbrown Status New => Under Review
2009-06-29 20:22 msbrown Assigned To => ajosey
2009-06-29 20:22 msbrown Name => Mark Brown
2009-06-29 20:22 msbrown Organization => IBM
2009-06-29 20:22 msbrown Section => dlsym
2009-06-29 20:22 msbrown Page Number => 735
2009-06-29 20:22 msbrown Line Number => 24705
2009-06-29 20:22 msbrown Status Under Review => Resolved
2009-06-29 20:22 msbrown Resolution Open => Accepted
2009-07-01 16:09 Don Cragun Name Mark Brown => Geoff Clare
2009-07-01 16:09 Don Cragun Organization IBM => The Open Group
2009-07-01 16:09 Don Cragun Reporter msbrown => geoffclare
2009-07-02 15:48 geoffclare Note Added: 0000148
2009-07-02 15:48 geoffclare Status Resolved => Under Review
2009-07-02 15:48 geoffclare Resolution Accepted => Reopened
2009-08-27 17:04 Don Cragun Interp Status => ---
2009-08-27 17:04 Don Cragun Note Added: 0000209
2009-08-27 17:04 Don Cragun Status Under Review => Closed
2009-08-27 17:04 Don Cragun Resolution Reopened => Duplicate


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker